Problems, need help? Have a tip or advice? Post it here.
19 posts Page 2 of 2

I think I can see what could be going wrong.

But first, a little correction - only the first image you posted is that of KCFinder.
The next two are of Plupload - a multi-file uploader being used by the gallery for several versions.
The last, of course, is our old uploader.

Coming back to the problem at hand -
The following image of KCFinder you posted does not show any text error message which shows that the called routine simply died before it could gracefully return an error message
KCfinder upload error - not gallery.jpg
KCfinder upload error - not gallery.jpg (17.79 KiB) Viewed 2239 times

This strongly suggests that PHP is running out of memory while processing the uploaded image.

To test our hypothesis, please place the following line at the very end of couch/config.php
Code: Select all
@ini_set( 'memory_limit', (int)ini_get('memory_limit') * 3 . 'M' ); // triple memory for testing

Alternatively, you can also try amending the 'memory_limit' setting in php.ini directly

Try uploading the image through KCFinder again and see what happens. Try nudging the memory up in case you still get the error.

Please let us know how you fare.

The errors you report through rest of the images (plupload and old filemanager) are basically in place to prevent the kind of dying out we saw in KCFinder above - they generate an error message before allowing PHP to begin processing an image and, possibly, die in the process.

Both plupload and the filemanager have separate settings where we specify the max size of the images. It is set to 2MB which is usually big enough. You can change them at these places -

Plupload: (find the 'max_file_size' setting)

Old filemanager: (find the '$Config['k_max_upload_size']' setting)

Hope this helps.
Please let us know.
thanks for your help KK - unfortunately increasing memory didn't work - I went up to * 20 and stopped trying.

I changed the Plupload 'max_file_size' setting from 2mb to 12mb and within the gallery upload appeared to successfully upload a 5MB image. But strangely the image then disappeared completely and isn't uploaded at all - no error message.

The setting for the old filemanager was already 0 - no limit.

As others have commented on the forum images are often a problem for clients who have absolutely no aptitude for this sort of thing! I am going to look round for a free downloadable - simple to use - utility that will allow clients to resize/crop images before uploading - any suggestions?
Can you please let me know the current memory_limit setting of your php.ini?
I didn't make any changes via php.ini to memory limit (just via config.php)
sorry - just realised what you meant - just checked it and it's set to 128M
OK. Thanks.
It is quite possible that our approach through config.php is not acceptable on your server and so it is not making any changes to the memory.

Can you please try setting that value to a higher number, say 256, via php.ini?
Make sure that the new value is indeed getting accepted.
(you can place
<?php phpinfo(); ?>
in any of your Couch templates to get an output of the current settings. Please find the 'memory_limit' setting and ensure that memory has indeed been increased).

If the value does not increase, you'll have to contact your hosting provider for help in getting it done.

Keep us posted.
hi again and thanks for your time on this ... I successfully increased the memory_limit to 256 but upload still failed with the 'ATTENTION!' ERROR.

I think it is reasonable to ask the website owner to get to grips with resizing their images ;) I'll point them in the direction of a free image resizer that they can download and use.
Unfortunately, that is how it looks like :)
I am sorry I couldn't be of much help.

That said, can you please email me the very image that is causing the trouble?
I'd like to find out just how much memory is required to process it.
For science's sake :)

I had the same problem. Here is the fix :

edit this file ->


at line 109 ::

max_file_size : '2mb',

change it to '256mb' and it's working
19 posts Page 2 of 2

Who is online

In total there are 24 users online :: 0 registered, 0 hidden and 24 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 24 guests