Important announcements from CouchCMS team
53 posts Page 5 of 6
Previous 1, 2, 3, 4, 5, 6 Next
@malax

As mentioned in the original post (quoted below), you need to regenerate the .htaccess file as with this addon the rules will change -
If your site was already using prettyURLs before activating this addon then you'll likely already have a .htaccess file you generated previously.
You'll still need to regenerate the rules and place them into the .htaccess file because this addon will add new rules of its own that have to be placed in the .htaccess file.

The last line is important - using prettyURLs with this multi-lingual addon expects a new set of rules in .htaccess file. So, in the future, if you happen to add a new language or modify the language-code of any existing language, you'll need to regenerate the rules and then update the .htaccess file with them

Hope this helps.
Thanks for replying, and yeah that's the problem I've seen what the new rules should look like (in multi-lang.php), but I just cannot get the rules to update with gen_htaccess.php in the backend. :? I keep getting the same output as in the file I've linked previously.
So, since I just can't for the life of me get the rules to regenerate on their own with the addon, I resorted to adjusting them manually. I've made the changes to the .htaccess but I made a mistake somewhere with the home page (index.php) rewrite (all the other pages are rewriting ok) I get File not found, like there is no such file in the subdirectory. I would really appreciate if someone could just take a look at the new file (http://www.salonacatering.com/htaccess.txt) and help me correct it, please, cause I don't know what I'm doing, really. Thank you.
@malax, could you please let me know in what way gen_htaccess.php is not working for you?
What happens when you click on its link?
it generates htaccess but rewrite rules are not changing, they are the same as if the addon does nothing, like so:
Code: Select all
#DO NOT EDIT BELOW THIS

RewriteRule ^index.php$ "" [R=301,L,QSA]

RewriteCond %{REQUEST_FILENAME} -d [OR]
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule . - [L]

#vjencanja.php
RewriteRule ^vjencanja$ "$0/" [R=301,L,QSA]
RewriteRule ^vjencanja/$ vjencanja.php [L,QSA]
RewriteRule ^vjencanja/.*?([^\.\/]*)\.html$ vjencanja.php?pname=$1 [L,QSA]
RewriteRule ^vjencanja/([1-2]\d{3})/(?:(0[1-9]|1[0-2])/(?:(0[1-9]|1[0-9]|2[0-9]|3[0-1])/)?)?$ vjencanja.php?d=$1$2$3 [L,QSA]
RewriteRule ^vjencanja/[^\.]*?([^/\.]*)/$ vjencanja.php?fname=$1 [L,QSA]
RewriteRule ^vjencanja/[^\.]*?([^/\.]*)$ "$0/" [R=301,L,QSA]
...
Are you sure the $cfg['prettyurls'] setting in the addon's config is set to '1'? Please check.
Oh, now its working, thank you.. this "page not found" threw me off, so I kept changing the setting for prettyurls back to 0; didn't realize its the condition for the function to work. Sorry to have bothered you.
Not a problem :) I am glad it is working now.
Looks promosing! One thing to address: What if you have a page that is online since a decent amount of time and has a good SEO ranking. As I understood from the comments here if I make the site multi language ready, the original URLs will not work any more. I fear that this will have an impact on SEO ranking and people not finding the page from external links.

My suggestion: Integrate an option to let the main language remain with the original URL, without the language shortcut. Using this option it would be possible to extend the page to a multi language page in a safe way, e.g.

http://www.mysite.com/blog/article.html -> default language woth original URLs
http://www.mysite.com/fr/blog/article.html -> other language with language specific URLs

Is this already possible?

It would be great.
Hi,

This Add-on is great! I still need to post my issues with the search (from above) which I will get around too but I have one more issue....

How would you setup 404 (and other errors) for this solution? I've set the ‘ErrorDocument’ line in the .htaccess to be ‘ErrorDocument 404 /404.php’ which is where the template sits however I don’t get the right results.

I’m working with 2 languages English and French. If I go to a missing page at the root of the domain, for example
Code: Select all
http://localhost:888/my-missing-page
then this forwards to
Code: Select all
http://localhost:888/en/404/
and shows the custom 404 page which is correct however if I try the same thing on either of the sub directories, i.e.
Code: Select all
http://localhost:888/en/my-missing-page
or
Code: Select all
http://localhost:888/fr/my-missing-page
then I just get the default ‘Page not found’ page.

Is it possible to setup so that you can have a 404 for each different language that works within the virtual directories?

Thanks
Daz
Previous 1, 2, 3, 4, 5, 6 Next
53 posts Page 5 of 6

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 1 guest

cron