Problems, need help? Have a tip or advice? Post it here.
23 posts Page 2 of 3
it doesn't pick up that theres any php file with the Couch code in. It's as if the database doesn't see the php? Any ideas?
Seems your web server is not configured to treat ".php" files as executables and hence is simply returning them as HTML files.

I think you should contact your web host.
I noticed in todat that several changes are indeed not showing in the admin panel
in my case i am not able to get the Full cke editor + my home page is not getting picked up as template..

i put in the tags to call the couchcms

Regards,
Ben
Hi and welcome @bsit,

If you have already tried the troubleshooting tips discussed in this thread, could you post the contents of your template file?
Yes I have.

Contact page (working, visible in my admin panel)

Code: Select all
<?php require_once('kvcms/cms.php'); ?>
<cms:template title='Contact Pagina' />
<!DOCTYPE html>
<!--[if lt IE 7 ]> <html class="ie ie6 no-js" lang="en"> <![endif]-->
<!--[if IE 7 ]>    <html class="ie ie7 no-js" lang="en"> <![endif]-->
<!--[if IE 8 ]>    <html class="ie ie8 no-js" lang="en"> <![endif]-->
<!--[if IE 9 ]>    <html class="ie ie9 no-js" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en"><!--<![endif]-->
    <head>
        <meta charset="utf-8" />
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
        <link href="css/content.css" rel="stylesheet" type="text/css">
        <style type="text/css">
        .no-js body .freestyle {
   font-size: 36px;
}
        </style>
        <script src="https://maps.googleapis.com/maps/api/js?sensor=false"></script>
    </head>
    <body>
    <cms:editable name='contact-pagina' toolbar='full' type='richtext'>
      <div id="content" style="color:#fff;" >
<!-- Content starts here -->
            <h1> Contact </h1>           
    <div id="contentBox" style="margin:0px auto; width:100%">
<!-- columns divs, float left, no margin so there is no space between column, width=1/3 -->
    <div id="column1" style="float:left; margin:0; width:45%;">
    </div>
    <table width="100%" cellpadding="0" cellspacing="10" border="0">
    <tr>
        <td width="50%" valign="top">
               <p style="border-style:solid; border-color:#CCC; padding: 25px;">Feestzalen De Kievit <br><br>
     Korte Heuvelstraat 14<br>
     B-2920 Kalmthout<br><br>
     Email: <a href="mailto:info@feestzalendekievit.be">info@feestzalendekievit.be</a><br><br>
     Tel: 03/666 93 70<br>
     GSM: 0485/53 06 60<br>
    GSM: 0478/47 07 50</p>
        </td>
        <p>Heeft U een opmerking over onze klassiekers uit de keuken, over onze bieren of over onze gastvrijheid? <br>
      Of wil U gewoon meer informatie over “De Kievit” <br>
Geef gerust een seintje.</p>
   </table>
    </div>
    <!-- Content ends here -->
    </cms:editable>
    </body> 
</html>
<?php COUCH::invoke(); ?>





Home page (not visible in admin panel) (see attachment)

Code: Select all
<?php require_once('kvcms/cms.php'); ?>
<cms:template title='Home' />
<!DOCTYPE html>
<!--[if lt IE 7 ]> <html class="ie ie6 no-js" lang="en"> <![endif]-->
<!--[if IE 7 ]>    <html class="ie ie7 no-js" lang="en"> <![endif]-->
<!--[if IE 8 ]>    <html class="ie ie8 no-js" lang="en"> <![endif]-->
<!--[if IE 9 ]>    <html class="ie ie9 no-js" lang="en"> <![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en"><!--<![endif]-->
    <head>
        <meta charset="UTF-8" />
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
        <link href="css/content.css" rel="stylesheet" type="text/css">
       
    </head>
    <body>
   <cms:editable name='welkom-pagina' toolbar='full' type='richtext'>
      <div class="sc-content" id="content" style="color:#fff;" >
           <!-- Content starts here -->
            <h1> Welkom </h1>
       
            <p>Ons team wenst u van harte welkom op onze nieuwe website. Hier vindt u alle informatie terug die u zoekt. <br>Voor vragen of meer informatie, aarzel niet om contact met ons op te nemen.</p>
                         <br>
         <img src="images/pentekening.jpg" style="float:left; margin: auto; "/>
         <img src="images/pentekening4.jpg" style="float:left; margin: auto; "/>
           <!-- Content ends here -->
        </div>
</cms:editable>      
    </body>
</html>
<?php COUCH::invoke(); ?>

Regards,
Ben

Attachments

<-bump->

anyone? :?:
Apologies @bsit, I seem to have lost sight of your reply.

I tested your code and when I visited the template as super-admin, got the following message
ERROR: Tag "editable": 'name' contains invalid characters. (Only lowercase[a-z], numerals[0-9] and underscore permitted. The first character cannot be a numeral)

I rectified the 'name' of the region from 'welkom-pagina' to 'welkom_pagina' (i.e. used underscore) and the template got registered just fine.

Hope it helps.
I'm having the same issue. I pasted the recommended code on the page:

<cms:if k_user_access_level ge '10' >
<p><a target="_blank" href="<cms:admin_link />">EDIT</a></p>
<cms:else />
<h3>You cannot edit!</h3>
</cms:if>

I am receiving the else condition which displays the string that "I cannot edit." I am definitely logged in as the super admin, and even checked the SQL database which confirms my access level is 10, disabled is 0, and system is 1.

Its frustrating that I have no ability to make changes to the admin panel. I'm trying to fix our meta descriptions so that we don't have duplicate meta descriptions, but I'm not able to add a new editable text field because of this.

I hate to say it, but we're in the process of planning for a new web site, and I'm leaning towards leaving couch behind because of all the issues I've had with it. I'd really appreciate some support as this issue is hurting our SEO.
@tylired, the best I can do to give support is take a look at the problem personally.
If it is ok with you, PM me the super-admin access creds to your site please.
Has this problem every been solved!? I am having the same problem, and according to this thread the problem has been on going for a few years now. I am a new couch user and so far am loving it, but this is a serious problem and may force me to look elsewhere.

I'm logged in as super admin and the database won't update.
Hi and welcome @kralcx!

There is no problem per se, it is a feature. This issue has almost always proven to stem from user misunderstanding/error.

Have you visited a cloned page of the template?
23 posts Page 2 of 3

Who is online

In total there are 3 users online :: 1 registered, 0 hidden and 2 guests
(based on users active over the past 5 minutes)

Users browsing this forum: genxcoders and 2 guests