Problems, need help? Have a tip or advice? Post it here.
4 posts Page 1 of 1

I've been testing a site here:

I've created a rss.php file but it doesn't seem to work on my server. It re-directs to the couch login page instead of the xml feed. On my localhost however it works fine. All my other .php files work perfectly. Any ideas? Is this a bug or have I done something really stupid?

Many Thanks

Feed Address:

Code: Select all
<?php require_once( 'login/cms.php' ); ?><cms:content_type 'text/xml' /><cms:concat '<' '?xml version="1.0" encoding="utf-8"?' '>' />
<rss version="2.0">
    <title>EcoControls News</title>
    <description>Latest EcoControls News; Commercial Lighting Controls from Mode Lighting</description>
    <pubDate><cms:date format='D, d M Y H:i:s' gmt='1'/> GMT</pubDate>
   <cms:pages masterpage='news.php' limit='10'>
        <title><cms:show k_page_title /></title>
        <link><cms:show k_page_link /></link>
      <pubDate><cms:date k_page_date format='D, d M Y H:i:s' gmt='1'/> GMT</pubDate>
            <cms:show news_content />

<?php COUCH::invoke(); ?>

I couldn't spot anything wrong with the code. The only thing I can suggest is to double check the "Access Level" under the page's "Advanced Settings". Make sure it is set to "Everybody". KK may be able to assist you further.
I can only second what cheesypoof suggested - please check the access level set for the template.
Cheers guys,

It seems making this into a template did the trick.

I added
Code: Select all
<cms:template title='RSS' />
so that it appears on the CMS screen even though it doesn't need any editable regions.

Many thanks!
4 posts Page 1 of 1