Problems, need help? Have a tip or advice? Post it here.
6 posts Page 1 of 1
Im getting this error when i upload it
Could not connect to database

Access denied for user 'database_usernam'@'localhost' (using password: YES)

everything is in ioncube
no one know the problem?
Hi,

Let us first make sure that we can connect to the database from outside Couch.
Please create a php file (say. test.php) and place the following code within it.
Make sure to replace the "localhost", "username", "password" and "dbname" with values you have placed in couch's config.php file.

Code: Select all
<?php
mysql_connect("localhost", "username", "password") or die(mysql_error());
echo "Connected to MySQL<br />";
mysql_select_db("dbname") or die(mysql_error());
echo "Connected to Database";
?>


Access this script and confirm if you can at all connect to the database.
wait is he config file the config.example.php file in there because i see no configuration all i see is

<?php
/*
CouchCMS
Copyright(c) 2009 - 2010 kksidd@gmail.com

THIS IS COPYRIGHTED SOFTWARE
PLEASE READ THE LICENSE AGREEMENT
*/
if ( !defined('K_COUCH_DIR') ) die(); // cannot be loaded directly

// 0.
// Set the follwing to 1 to put your site in maintenance mode.
// In this mode only admins will be able to access the site while the visitors will be
// shown the 'Site undergoing maintenance' message.
define( 'K_SITE_OFFLINE', 0 );

// 1.
// If neccesary, define the full URL of your site including the subdomain, if any.
// V.IMP: Don't forget the trailing slash!
//define( 'K_SITE_URL', 'http://www.test.com/subfolder1/subfolder2/mysite/' );

// 2.
// Your Time Zone
// Example values (note how :15, :30, :45 will be entered as .25, .5 and .75 respectively):
// +12.75 New Zealand (UTC+12:45)
// +8.75 Australia (UTC+08:45)
// +5.5 India (UTC+05:30)
// +1 Germany (UTC+01:00)
// 0 United Kingdom (UTC
The config.example.php needs to be renamed to to config.php before you begin installation.
This is fully documented in http://www.couchcms.com/docs/tutorials/ ... -site.html

Once renamed find the following lines and add your MySql info into them

Code: Select all
// MySQL settings 
    // 4.
   // Name of the database
   define( 'K_DB_NAME', 'database_name' );
    // 5.
   // Database username
   define( 'K_DB_USER', 'database_username' );
    // 6.
   // Database password
   define( 'K_DB_PASSWORD', 'database_password' );
    // 7.
   // MySQL hostname (it will usually be 'localhost' )
   define( 'K_DB_HOST', 'localhost' );
oki got it working now
6 posts Page 1 of 1

Who is online

In total there are 3 users online :: 1 registered, 0 hidden and 2 guests
(based on users active over the past 5 minutes)

Users browsing this forum: mobilemcclintic and 2 guests

cron