Problems, need help? Have a tip or advice? Post it here.
7 posts Page 1 of 1
Hello,

I have followed the tutorial on the website for installation, including looking through the support forum extensively for an answer, am logged in as the super admin and visited the template page in the same browser, but still am not getting any templates to display.

I have looked at the source code for one of the templates I am trying to upload into the CMS and after the </html> tag it says "ERROR: Failed to insert record in K_TBL_TEMPLATES".

here a link to the template: http://www.glacialridge.org/physicians_testing.php, so you can take a look at the source code.

I do have this at the top of the page:
<?php require_once( 'grhs_admin/cms.php' ); ?>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>

and this at the bottom:
<?php COUCH::invoke(); ?>

I've been at this for a couple of days so anybody have any help it would be appreciated.
Hi and welcome to our forums.

We've had some similar reports in the past too but they were about this problem cropping up every once in a while. Yours is different because it seems to be consistently happening (so I gather) and also that you have noticed the explicit error message in the generated HTML.

I'll need to dig further into this issue and I'd be grateful if you could provide me with backend access to your site (CPanel or anything else that you use). Please PM me the credentials if it is ok with you (I'll also be requiring Couch's admin name/pwd).

Thanks
Hi,

Thank you for entrusting me with your site's credentials.
The FTP server, however, is timing out on me so I haven't been able to get in yet.

I had a second look at your post and (I really should have got it earlier) I think I can see what the problem is.

Couch, as of the current release version, has problems with long template names (actually anything longer than 20 characters). This has been discussed at viewtopic.php?f=2&t=138&p=446

The name you chose for your template, 'physicians_testing.php', is longer than the limit and this should be the cause of this problem.
I think everything will work ok if you use a slightly shorter name.

I must add that this limitation has been removed in the version scheduled to release in the next few days but for now you'll have to manually apply the fix as discussed in the thread mentioned above or go for shorter template names.

Please do let me know if this helps.
Rock on KK, that worked.

I'll be staying tuned for the newest version. Thanks a bunch for your VERY timely and quick response.
You are most welcome :)
Please feel free to post in any problem you happen to run into.
Just got the same problem and it was the template name that made it do a error. The weird thing was that i had a template name with the same name but that one worked :S
I mean page name. like hippo_kebab_drinkingcoke.php
That one was to long
7 posts Page 1 of 1

Who is online

In total there are 15 users online :: 0 registered, 0 hidden and 15 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 15 guests

cron