Problems, need help? Have a tip or advice? Post it here.
9 posts Page 1 of 1
I've been following the tutorial step by step and in the two instances of using the Embed call I can get neither working.
I've even created the simplest test possible and still cannot get anything to occur.
The show call does work but I cannot get the hello.inc file to get pulled in.


code within a page named: test.php
Code: Select all
?php require_once( 'couch/cms.php' ); ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
   <title>Test File</title>
   <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
</head>
<body>
   <cms:show 'text above embed' />
   <cms:embed 'hello.inc' />

</body>
</html>


code within a file named hello.inc - I've placed this file in both the "snippet" folder and in the root.
Code: Select all
<b class="title"><cms:show 'Hello World' /></b>


Any assistance in what to try or test for is greatly appreciated.
Hi mkenney,

This is very strange. Never had any trouble with embed and what you are using is a straightforward statement.
Could you please attach both the files here for me to see?

Thanks
OK so what's the trick of attaching a file, I've tried renaming the file extension to .txt, .html, .doc, no extension at all and none of them are allowed? :mrgreen:

I created a page on my test site where you can download the files - http://couch.2bluenewts.com/download.html
Hi,

Cannot download the files from your site (they are getting executed because of .php extension).
Please Zip up both the files and either place them on your site or attach them here. Zip files can be attached without any problem.
Yeah you'd have to do a "Save Target Link as" in order to download the files to your computer. But I've attached the zipped files.

Attachments

Hi,

I downloaded and tested out the files on my system.
Everything is working as expected.

Something is wrong on your particular setup.
So now, can you give me guest FTP access to your site?
This is an intriguing problem and I'd like to get to the bottom of it.

Thanks.

P.S.
I'll also need access to your Couch admin panel.
Please use the PM if you decide to send in the credentials.
Hi mkenney,

Thanks for entrusting me with the credentials.

I logged in and had a look and it seems that you are placing the 'hello.inc' file in the wrong snippets folder.
You'll find a folder named 'snippets' already existing within your Couch folder (or whatever you might have renamed it to). This is where the embed tag starts looking.
I placed the hello.inc file there and everything started working okay. Please verify.
KK - so what you're trying to tell me is that if my reading comprehension skills were up to the task we wouldn't have had this little back and forth? :oops:

Thank you very much for all your time and effort on this.
Hope you have a safe and joyous New Year.
You are welcome Mike :)
Wishing you too a happy new year.
9 posts Page 1 of 1

Who is online

In total there are 5 users online :: 1 registered, 0 hidden and 4 guests
(based on users active over the past 5 minutes)

Users browsing this forum: Google [Bot] and 4 guests

cron