Problems, need help? Have a tip or advice? Post it here.
6 posts Page 1 of 1
Hi,

I'm trying to enable the Pretty URL function (following the explanation in the Documentation), but when I try to access the gen_htaccess.php file in my browser I just get a blank page.

The Pretty URLs work on the pages but then I receive a 404 error page.

Any ideas?

Thanks in advance!

G.
As a security measure, gen_htaccess.php will output nothing if it is accessed by a non-admin. Can you please confirm that you are accessing it through the same browser in which you are logged on as the super-admin?

..The Pretty URLs work on the pages but then I receive a 404 error page
Pretty URLs will require the .htaccess file generated by gen_htaccess.php. You mentioned that gen_htaccess.php was not working. Let us first try and get the required .htaccess.
Thanks for getting back to me!

I've managed to accesss the gen_htaccess.php file – I wasn't logged in as the super-admin!

However, when the pages show up in the browser they have lost all the CSS styling. This has happened after I enabled Pretty URLs.

Any thoughts?

Many thanks,

G.
That happens when you are using relative paths for the CSS/image files. e.g
Code: Select all
<link rel="stylesheet" href="css/styles.css" />

Just convert them to absolute path to make the links work again.
Either prefix the paths with a '/'
Code: Select all
<link rel="stylesheet" href="/css/styles.css" />

or prepend them with the full path of your site this way-
Code: Select all
<link rel="stylesheet" href="<cms:show k_site_link />css/styles.css" />
Great! It works!

Thanks for your patience.

G.
You are welcome :)
6 posts Page 1 of 1

Who is online

In total there are 19 users online :: 0 registered, 0 hidden and 19 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 19 guests