Problems, need help? Have a tip or advice? Post it here.
20 posts Page 1 of 2
When I'm trying to login using the "extended" addon, so it's a custom login page.
The url is

When I try to login, most of the time (not all the time) I get the Cookies must be enabled to use CouchCMS error.
If I open a incognito window and try again, it will work all the time though.

Cookies are working fine on my browser. I'm not having any issues whatsoever on any site except when I try to log in my admin panel.

In the config file, I have defined the k_site_url by the way.

I had this issue for a long time, but was always opening an incognito window to login, but I'm tired of it.
Also, there's multiple other users using the CMS, and no one seems to have the same issue.
So it's probably something on my Browser for some reasons, but I can't find anything that could make this not work.

I have Adblocks installed, not sure if it does anything.

Is there a way to disable this error and let me in? Or some sort of a hack that I can add in the code?

I have built numerous CouchCMS sites in the past, and never had that issue. But at the same time, I have never used the Extended user Addon, so this must be linked.

I thought I would simply switch to Safari, thinking it might be just me having the error in my business team, but we ordered a new laptop for one of the team member, and its using Edge latest version.

After a week of using it, she sent me a screenshot showing the same error. So it seems it's happening to more people than just me.

What is happening and how can I fix this?
I see a ton of people looked at this thread so I'm probably not the only one having this issue.

I guess this would be related to using the Advanced users addon and the custom login page?
Would it fix the issue to revert back to the default CouchCMS login page?

Thank you
Adding website to browser exceptions helps. Same as turning off the advanced tracker protection (on Firefox the button is to the left in the URL bar). Sam day as your previous post I mentioned a new tweak for Couch to disable that behavior permanently but I presume configuring the browser would be the correct / better way, as it's the browser who may reject the cookie, i.e. not the CMS problem (I may be corrected here by @KK himself).

I searched in your post history and found that you talked about this in your Ryazania theme thread.
Any chance you can share the addon or some info about how you managed to disable the cookie prompt?

I find it strange that you would have to edit default browser settings to use a CMS. Like I said, it's happening to me but now to my colleague who's using a brand new computer with factory settings Edge installed. So in my situation I feel like the best would be to disable this feature completely to make sure my team members can log in without any issues.

Thank you very much
@larin555, is the login template (extended), by any chance, getting cached? Please check you have explicitly used <cms:no_cache /> in it at a point that gets executed unconditionally.

Please confirm.

I checked in the entire project folder, and there's only once place where "<cms:no_cache />" is used, and it's in a template file that is not related to the login system (it's a simple clonable page admin template "content_form_....html" file)

Any idea where I should look next?

Thank you very much
Could you please try the following?

Edit your extended login template and place a <cms:no_cache /> statement immediately below the <?php require_once( '../couch/cms.php' ); ?> at the top.
Empty your 'couch/cache' folder (or login as admin and save any page there which will have the side-effect of busting the cache).

Let me know if this helps.

I tried and nothing changed. Still getting the error.
You're talking about editing the "users/login.php" page right?

You're talking about editing the "users/login.php" page right?
That is right.

Ok, so now try this -
edit 'couch/auth/auth.php' and comment out line 138 to make it
Code: Select all
// return $FUNCS->raise_error( $FUNCS->t('prompt_cookies') );

Please let me know if things go normally now for you.
I already tried that when I was trying to fix it by myself, but all it does is that it reloads the login page but without showing the error. So I can't log in, same as before.

Any other ideas? Thanks a lot!
20 posts Page 1 of 2