Problems, need help? Have a tip or advice? Post it here.
5 posts Page 1 of 1
Hello,

One of my client is having some issues when using Mosaics.

He adds a tile, but for some reasons after adding 4 on one of the page, when he tries to add another one, clicking the "Save" button in the tile popup window will result in a blank popup, and nothing will happen. The popup will stay there with nothing in it.

I thought it might be a memory limit issue, but I have upgraded it to 256M and it's still doing the same thing.

On another page of his site, he can add up to 7 tiles and then it starts doing the same thing on that page.
Clicking "+ Section" will open the tile popup, he can fill the fields, but once he clicks "Save" to save the content inside the tile (not the actual page, the tile) it will break only inside the popup window.

Any ideas? Thanks a lot

He's running Couch 2.1
Please upgrade to the latest commit available on https://github.com/CouchCMS/CouchCMS as it has a fix for a similar issue.
Hope it helps. Do let me know.
Thanks KK.

I have updated Couch but the error is still occurring.

I think I found the issue, but not the solution.
The tile that was causing the issue had the following regions:

Code: Select all
            <cms:editable name='standard_block' label='Contenu FR' type='richtext' />
            <cms:editable name='standard_block_en' label='Contenu EN' type='richtext' />


One of them was containing a table (generated with the Richtext editor).

So I tried creating adding a fresh tile with these fields, and added a blank table just to see if the table was causing the issue, and that's what is breaking the page for some reasons.

I can add that tile with some dummy text, and it will work.
But if I add an HTML table using the button in the toolbar, it will break.

I also tried keeping the same HTML code that was in the problematic region, only deleted the <table>... elements, saved, and it's working fine after that.

Any ideas?

(I wanted to try with Nicedit but for some reasons, most of the buttons are not working in the toolbar. Only "Italic, Bold and underline" are working. I cannot paste the HTML code of that table since the "HTML" button is not doing anything)
Yes, I am aware that nested table was the problem - this is precisely what had been fixed (https://github.com/CouchCMS/CouchCMS/co ... fd63fa1fcd).

What do you see as the version of Couch in admin-panel sidebar? I am interested in knowing the 'build number' which should now be showing as 20200116 - is that the case? If not, the update was not complete.

Please check and let me know.
It says "CouchCMS Version 2.2.1 (20200116)".

I also check the few files that were edited on that link :
https://github.com/CouchCMS/CouchCMS/co ... fd63fa1fcd

Checked if the changes were also on the files on my server, and everything is fine.

I kept the Snippets, Theme and Upload folders as is (so not replaced by the ones from the latest build)

Any ideas?

Thanks
5 posts Page 1 of 1

Who is online

In total there are 12 users online :: 1 registered, 0 hidden and 11 guests
(based on users active over the past 5 minutes)

Users browsing this forum: Google [Bot] and 11 guests