Problems, need help? Have a tip or advice? Post it here.
6 posts Page 1 of 1
I've defined editable regions, eg:-
Code: Select all
<cms:editable name='topline'>
      <h1>What We Do</h1>
      <p class="lead">Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. </p>
    </cms:editable>

The page 'index.php' is listed but keeps reporting 'No editable regions defined' even after refreshing both the page and the admin page.
Hello again!

Seeing your editable region code one thing is pretty evident that it is incomplete.

I will try to explain and site an example.

If you visit the documentation at Starting off simple - the About-Us page and scroll down to the Defining editable regions region you will find the editable defined in exactly the away that you are using. It states that:

<cms:editable name='main_content' type='richtext'> original content </cms:editable>


If you notice, the type attribute is not defined in your definition of the editable region. It is not that the field will not be displayed in the backend but for the definition provided by you a textarea will be displayed by default.

Now since you have also stated,
The page 'index.php' is listed but keeps reporting 'No editable regions defined' even after refreshing both the page and the admin page.

I suppose this should not be the reason but I will request you to check it. Have you inserted both the boiler plates, i.e.:

Code: Select all
<?php require_once( 'couch/cms.php' ); ?>
    ...
<?php COUCH::invoke(); ?>


If the above is also set right, then please make sure your XMPP/WAMP/LAMP/MAMP server is started. It happens that due to cookies being enabled (which is a default requirement of Couch CMS) the page loads and you are able to log into the admin panel too but updates are not picked up.

If the above is also set correctly, please post the complete template code here and I (or someone from the forum) will help you to sort the issue.

Regards,
GenXCoders (Aashish)
Image
where innovation meets technology
genxcoders wrote: Hello again!

<cms:editable name='main_content' type='richtext'> original content </cms:editable>


Now since you have also stated,
The page 'index.php' is listed but keeps reporting 'No editable regions defined' even after refreshing both the page and the admin page.

I suppose this should not be the reason but I will request you to check it. Have you inserted both the boiler plates, i.e.:

Code: Select all
<?php require_once( 'couch/cms.php' ); ?>
    ...
<?php COUCH::invoke(); ?>


If the above is also set right, then please make sure your XMPP/WAMP/LAMP/MAMP server is started. It happens that due to cookies being enabled (which is a default requirement of Couch CMS) the page loads and you are able to log into the admin panel too but updates are not picked up.

If the above is also set correctly, please post the complete template code here and I (or someone from the forum) will help you to sort the issue.

Regards,
GenXCoders (Aashish)

Thanks for your help.
Adding type='richtext' makes no difference.
If the boilerplates were not there then surely the page would not be listed in the backend? The boilerplates are there anyway!
This is not on a local development machine but on my live website so XMPP/WAMP/LAMP/MAMP is surely irrelevant?
@oldcelt, invariably almost always the reason for this problem is failing to visit the modified template as super-admin.
This is discussed at length in the following thread - viewtopic.php?f=4&t=8059
Please try the steps mentioned there.

In case the problem persists, please PM me the FTP+Couch creds of your site and I'll take a look at the issue.
--
unlimited time premium coding support per project - PM or email me or discuss in topic
active topics
KK wrote: @oldcelt, invariably almost always the reason for this problem is failing to visit the modified template as super-admin.
This is discussed at length in the following thread - viewtopic.php?f=4&t=8059
Please try the steps mentioned there.

In case the problem persists, please PM me the FTP+Couch creds of your site and I'll take a look at the issue.

I am logged in as super-admin: added the analysis code and refreshed the page:-
result message "You cannot edit!".

I don't understand exactly what you mean by "please PM me the FTP+Couch creds"?

LATER:
I found the reason for the problem. I added a redirect in the <head> section to establish the canonical web address. i..e. I have two addresses pointing to the same page; one with www and the other without www. For SEO reasons I wanted to establish one as the canonical address. I wonder if this is necessary with the way Google now works? Looking at my Google Webmaster pages, I see that only the one with www is being indexed!

Removing the canonical link line in the <head> section has restored order to the Couch backend.
6 posts Page 1 of 1

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 4 guests