Problems, need help? Have a tip or advice? Post it here.
5 posts Page 1 of 1
Hi there

We are currently trying out the couch search function on one of our pages and stumbled across a weird problem.
When adding the search function on one of our pages we simply get the following error upon searching:

Code: Select all
Could not successfully run query: Can't find FULLTEXT index matching the column list

The code used for the search function:

Code: Select all
               <cms:search_form processor='/search.php' />
         <cms:search masterpage="index.php" limit='10'>
                 <cms:if k_paginated_top >
                        <cms:if k_paginator_required >
                            Page <cms:show k_current_page /> of <cms:show k_total_pages /><br>
                        <cms:show k_total_records /> Pages Found -
                        displaying: <cms:show k_record_from />-<cms:show k_record_to />

                <h3><a href="<cms:show k_page_link />"><cms:show k_search_title /></a></h3>
                <cms:show k_search_excerpt />

                <cms:paginator />

We tried altering the KEYS in the table with the following sql query:

Code: Select all

The couch version with the first few tries was 2.0 but we upgraded to the latest version shortly after.

Thanks for your help!


It appears to be a case of database corruption (the fulltext table being particularly susceptible as it has to be MyISAM as opposed to InnoDB like all the other tables).

I recall only one other post discussing this problem - viewtopic.php?f=4&t=11062
As suggested there, please try repairing the database.

Hope it helps.

Thanks for the prompt reply!

We tried to repair the database as your post suggested however the problem still remain.
What would be the procedure to recreate the couch_fulltext table?
Sorry to hear about that.
Well, this is exactly the kind of event one saves backups for.
Any chance you happen to have a recent one?

Anyway, the particular error you are getting suggests the problem is with the 'indexes (indices)' and not with the table per se.
So, I think if you can still use gen_dump.php ( ... erver.html), try getting a database dump and then try recreating the site.

Make sure to change the 'K_DB_TABLES_PREFIX' setting in couch/config.php to add a new value e.g. 'new_' - this will create a new set of tables from the dump (and in the process automatically recreate the missing indices).

Please try it and let me know if it helps.

Luckily we had a backup. I did what you said and it worked this time.
The search function is working like a charm!

Thanks for your help KK!
5 posts Page 1 of 1

Who is online

In total there are 7 users online :: 0 registered, 0 hidden and 7 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 7 guests