I realized a problem with my couch powered website yesterday: On the list-view page i used this code:
Code: Select all
<cms:set my_category="<cms:gpc 'category' method='get' />" />
<cms:pages masterpage="post.php" paginate='1' limit='3' folder=k_folder_name start_on=k_archive_date stop_before=k_next_archive_date custom_field="tags=<cms:show my_category />">
                           <li class="post">
                              <a href="<cms:show k_page_link />" title="<cms:show k_page_title />">
                                 <img src='<cms:thumbnail news_img width='330' height='242' />' alt='img'>
                              <div class="post_content">
                                    <a href="<cms:show k_page_link />" title="<cms:show k_page_title />"><cms:show k_page_title /></a>
                                    <a class="comments_number" href="<cms:show k_page_link />#disqus_thread" title="Comments"><span class="arrow_comments"></span></a>
                                 <ul class="post_details">
                                    <li class="category">
                                       <cms:if k_page_foldertitle>
                            <cms:set my_category=k_page_foldertitle/>
                            <cms:else />
                            <cms:set my_category='Uncategorized'/>
                                       <a href="<cms:show k_page_folderlink />" title="<cms:show my_category />"><cms:show my_category /></a></li>
                                    <li class="date">
                                       <cms:date k_page_date 'h:i A, M j,Y'/>
                                 <p><cms:excerpt count='20' ignore='img'><cms:show news_content /></cms:excerpt></p>
                                 <a class="read_more" href="<cms:show k_page_link />" title="Read more"><span class="arrow"></span><span>READ MORE</span></a>
                  <h3 class="no_entries">No blog entries</h3>

I added this to the <cms:pages></cms:pages> that so i can be able to filter pages by tags:
Code: Select all
custom_field="tags=<cms:show my_category />"

Now if I add any new post and do not choose any tag for it at the admin page, I realised it doesn't appear on the front-end, as in it is excluded from all the list of news items on the list-view page but once I delete the custom_field the tag-less news post appears. Any help will be appreciated . Thank you all.