Problems, need help? Have a tip or advice? Post it here.
4 posts Page 1 of 1
Dear all, I was wonderng if you could help me out with this oddity:

I have a gallery implementation (presumably by the book - a gallery-src.php which is a clonable gallery and the page.php, where the gallery editable fields (gg_image, gg_thumb and description) are inserted in form of a lightbox). It works fine on localhost but with every image upload on server I am receiving an eror message like this:

Code: Select all
[Error] File: id=o_1busr56jbrs31mq51nbi60369pg, name=1200x400.jpg, type=image/jpeg, size=47767, origSize=47767, loaded=47767, percent=100, status=DONE, lastModifiedDate=Thu Nov 02 2017 08:52:08 GMT+0100 (CET) Info: response=<br />
<b>Deprecated</b>:  Methods with the same name as their class will not be constructors in a future version of PHP; phpExifReader has a deprecated constructor in <b>/data/web/virtuals/9034/virtual/www/winkcake/x02/couch2/includes/phpExifRW/exifReader.inc</b> on line <b>314</b><br />, status=200, responseHeaders=Date: Tue, 14 Nov 2017 08:43:33 GMT
Server: Apache
Expires: Mon, 26 Jul 1997 05:00:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Upgrade: h2,h2c
Connection: Upgrade, Keep-Alive
Last-Modified: Tue, 14 Nov 2017 08:43:33 GMT
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 217
Keep-Alive: timeout=2, max=500
Content-Type: text/html; charset=utf-8


Stranger yet, the images (or some of them at least) do upload none the less.

Permissions for /uploads are okay (777 recursively), limit of my hosting provider is sufficient too and I have also increased the limit in /plupload/upload.php (it actually occurs even with a single small file so size seems to not be the factor). I have noticed KK mentioning something about deprecated constructor. Well, something may have gone wrong during the website upload, I will have another look at it. But if you had an idea where the issue might be, do please drop me a message...

Thanks and Regards,

MiB

// edit: All files get actually uploaded, only each of them throws that error. I could disable that warning but would rather be interested what the root cause it. Just tried to empty the entire /uploads folder and change the mysql prefix for this couch instance (leaving the dame database) but to no avail...
Hi,

This problem was fixed in the version of Couch available at GitHub (https://github.com/CouchCMS/CouchCMS).

So you may either upgrade to that or, alternatively, patch just this single problem you reported by extracting only the 'couch/includes/phpExifRW/exifReader.inc' from the GitHub zip and putting it in your existing installation at the right path.

Hope it helps.
Thanks for the quick response, KK! Will proceed with the new version and as soon as I get anywhere, wil report back.
I am happy to confirm that (GitHub version) fixed the upload error alert issue on the server. ;o)
4 posts Page 1 of 1

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 3 guests

cron