Problems, need help? Have a tip or advice? Post it here.
5 posts Page 1 of 1
hi @KK

I using 2.1 beta, and found one place:

i using:
Image

but on backend i have this:
Image

I checked but couldn't replicate the issue - for me the width parameter is working as expected.

Please check if you are not overriding the type 'text' rendering template (I can see a line-break in your generated code which is not there in the default template).

If you think that is not the issue, please copy/paste your problem editable region definitions so that I may be able to test your exact code (screenshots are not helpful at all when it comes to code).

what it is file?
i didn't change templates at theme/_system

\admin\theme\_system\field_text.html code is:


Code: Select all
<input
    type="text"
    id="<cms:show k_field_input_id />"
    name="<cms:show k_field_input_name />"
    <cms:if k_field_rtl >dir="RTL"</cms:if>
    value="<cms:show k_field_value />"
    size="105"
    <cms:if "<cms:not k_field_simple_mode />" >class="text <cms:if k_field_is_deleted >readonly</cms:if>"</cms:if>
    <cms:if k_field_maxlength >maxlength="<cms:show k_field_maxlength />"</cms:if>
    <cms:if k_field_is_deleted >readonly="1"</cms:if>
    <cms:if k_field_width >style="width:<cms:show k_field_width />px;"</cms:if>
    <cms:show k_field_extra />
>



my tempalte code is:
Code: Select all

      <cms:editable type='text' name="product_color" label="Produkto spalva" validate='0' desc='Leidžiama nauduoti tik HEX kodą, pvz EEFF00, be grotelių' width='50' maxlength='6' />
      <cms:editable type='text' name="spec_nuolaida" label="Nuolaida procentais" desc='Įrašykite nuolaidos procentą, skaičių nuo 1 iki 99' width='50' />

That is the core file. It can be overridden by placing a template of the same name in 'couch/theme/sample' folder.
Please see if there is one there.

Get me the text you are using for your editable region definitions if you want me to check them out.

i didn't changed files in this folder

Image

I didn't change code at /theme folder

can it be, if my server has PHP Version 5.3.23 ?
5 posts Page 1 of 1

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 5 guests

cron