Problems, need help? Have a tip or advice? Post it here.
13 posts Page 1 of 2
Just uploaded our couch website on the test server. However if I try to access the url I get the message 'Page not found'. If I go to the control panel & login I am able to see the web page.

BTW I have not set the template to non-executable tag.

Please help need to send the url to the client.
Hi,

Perhaps it is a prettyURL related issue?

Please edit couch/config.php and set prettyURLs to '0'.
Next make sure there is no .htaccess file (generated by gen_htaccess.php on the previous installation) present in your main site's root.

Check if by making the above changes you can access the pages.
If you can, it is now that you should re-implement prettyURLs step-by-step.

Hope it helps.
Tried it but did not help, actually I found multiple htaccess files scattered in my local directory. Should I clean all from the uploaded site.
OK. You previously mentioned -
If I go to the control panel & login I am able to see the web page.
Does that mean that once you login as super-admin, you can see the web-page in the admin-panel or that you can now access the page on the front-end without that error?

What happens when you click 'view' or the magnifying glass icon from within the admin-panel? Do you still get the page not found error?
Once I login into the control panel as admin then only I am able to view the web pages in the front end. So if I keep the admin logged in I am able to view the entire website in separate browser tabs. Once I logout the error comes back again.
OK, thanks for confirming that.

Could you please edit any of the problem page, click the 'Advanced setting' dropdown on top-right and check what the 'Access level' is set to? It should be set to 'Everybody' for the page to be accessible to everyone.

In case that is not the cause, please PM me the FTP+Couch access creds to your site and I'll take a look at the problem myself.

Thanks.
Dont know if you have received the PM as it is showing it in outbox. Thefore sent you a mail.
Thanks.

I checked and found that the problem was occurring only with the index.php template.

The access permissions were fine and it was also not a prettyURL issue so it was a bit intriguing to find that only super-admin could access the template.

It came to my mind that this behavior (by design) is also seen in non-executable templates so perhaps the template was set with executable='0' using the <cms:template> tag.

As it happens, the <cms:template> tag was not being used at all in index.php.
Now, it is possible that at some time during the development you happened to use this tag and set the 'executable' parameter to '0'. Then later on you removed this tag from the template.

Just removing the tag wouldn't reset the executable param back to '1'.
So, I added the following explicitly to your template -
Code: Select all
<cms:template executable='1' />

Visited the changed template as super-admin and then logged out to check if it worked.

And, yes it did.
So, there you have the solution :)
Thanks a ton, this problem was really intriguing. :D
Hi KK

Sorry to trouble you again, however the problem has recurred, we did some editing in the php pages and the page not found is back.

Did you add the <cms:template executable='1' /> in any of the php pages?
13 posts Page 1 of 2

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 1 guest