Problems, need help? Have a tip or advice? Post it here.
2 posts Page 1 of 1
Dear CouchCMS community,

I'm having an issue with creating a RSS feed inside couchCMS.
Whenever I use <cms:content_type 'text/xml' /> or <cms:concat /> tags it seems like couch automatically adds some blank text behind the actual text.

I've tried creating a sample RSS feed from the website documentation.

Here's the code:
Code: Select all
<?php require_once( 'rlgadmin/cms.php' ); ?>
<cms:content_type 'text/xml' /><cms:concat '<' '?xml version="1.0" encoding="' k_site_charset '"?' '>' />
<rss version="2.0">
  <channel>
    <title>My Explosive News</title>
    <link>http://www.mysite.com</link>
    <description>News and articles written by me</description>
    <language>en-us</language>
    <pubDate>10 Jul 2007</pubDate>

    <item>
        <title>My Second News</title>
        <link>http://www.mysite.com/breaking/my-second-news.html</link>
        <description>This is my second news item.</description>
        <pubDate>10 Jul 2007</pubDate>
    </item>

    <item>
        <title>My First News</title>
        <link>http://www.mysite.com/my-first-news.html</link>
        <description>This is my first news item.</description>
        <pubDate>10 Jul 2007</pubDate>
    </item>
  </channel>
</rss>
<?php COUCH::invoke(); ?>



And here is the output:

Image


Can anyone help me out?
Found an issue!

My kfunctions.php had some empty space before the <?php tag
2 posts Page 1 of 1

Who is online

In total there are 12 users online :: 0 registered, 0 hidden and 12 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 12 guests