Problems, need help? Have a tip or advice? Post it here.
3 posts Page 1 of 1
Hi,

I was adding in some editable regions to a page. After making the changes, I attempted to go to the content edit page within Couch (which was working before the changes). I got a white page with the following error:

ERROR: Tag "input" 'name' contains invalid characters. (Only lowercase[a-z], numerals[0-9] hyphen and underscore permitted

It was working just moments before, so I checked the editable regions I had added and saw I had indeed used some invalid characters. I corrected these mistakes, refreshed the page whilst logged in as a couch admin, yet I still got the error.

Then I tried:

- Removing the editable regions I added
- Removing the whole block of code I added
- Reverting back to an earlier version of the code
- Deleting everything on the page except the PHP to invoke Couch

Each time I saved and refreshed the page whilst logged in as an admin. None of it worked. Even with absolutely no tags or "Inputs" on the page, I still get this error in the Couch app. It's nothing to do with any snippets as other pages using the same snippets are working fine.

Despite all this, the text I added within Couch whilst it was still working is still feeding through the existing editable regions.

I tried searching for some previous threads but none solved my issue.

I'm not sure what else I can try.

I am sorry about the trouble you are facing.

If I got it right, the admin-panel is now inaccessible, right?
This error should crop up only when editing the specific template that has the malformed editable-regions. If, however, that template happens to be the very first template that shows up upon entering the admin-panel, it'd appear as if the entire admin panel is inaccessible.

Please try accessing it using the following URL (of course, using the correct site address) -
http://your-site/couch/?o=users&q=list

That is the address for editing the users but the sidebar will now allow you to navigate through all the templates.
Only accessing the problem template should result in the error.

Please try refreshing the problem template now with the admin panel open in an adjacent tab of the same browser.
See if that helps.

If not and if your site is online, please PM me the FTP+Couch creds and I'll take a look.

Hi KK,

it was the admin panel page for that specific template that was inaccessible. The rest of it worked.

I ended up solving this problem by removing and readding the template. It's all working fine now. I'm not sure what went wrong!

Thanks
3 posts Page 1 of 1

Who is online

In total there are 10 users online :: 0 registered, 0 hidden and 10 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 10 guests

cron