Forum for discussing general topics related to Couch.
7 posts Page 1 of 1
Hi,
will there be Couch work on PHP 8.2 or 8.1?
Actually with Couch 2.3 there are some deprecated functions in Couch.
I have actual the problem that a customer has a redesign injury and I try to consult him if we need another cms or can use couch further.

Cheers
Hi,

The current version of Couch (from GitHub) is working fine with 8.1.
No reports yet on 8.2 but, of course, we'll keep making changes to ensure compatibility with newer versions of PHP as they get released.
Hi,
thanks for your reply!
Also on 8.1 I have a the frontend the output of error:
Deprecated: trim(): Passing null to parameter #1 ($string) of type string is deprecated in …/cms/tags.php on line 561

this also I got for explode(), strlen() at page.php, tags.php and functions.php and on the loginpage I got the error
Deprecated: setcookie(): Passing null to parameter #5 ($domain) of type string is deprecated in …/cms/auth/auth.php on line 273


Best
@KDJFS, there indeed will be several more deprecated calls in the current code -
these are warnings and can be safely ignored.

They should, however, definitely not be appearing as output of your page.
The current codebase does try to mute such warnings but, perhaps due to some particular setting on your server, you are getting to see some.

It is expected that on a production server, error displays should always be disabled, so you can do the following -
Code: Select all
In a php.ini file, you can add a line like “display_errors = off” (without the quotes). 
In an .htaccess file, you can add a line that says “php_flag display_errors off” (without the quotes).

That should take care of the issue for now.
Rest assured, all these deprecations will be taken care of shortly.
Hey,

nothing from that worked.
In the php.ini is `display_errors = off` declared and if i write `php_flag display_errors off`in the .htaccess it kills the whole website.
It is a nginx with apache tools hostet by Uberspace. So I think there is any fily where it is called.
But I havn't do this website I'm only the idiot who have to integrate some changes and the website is not really well written.
Not all hosts allow that .htaccess method so let us concentrate on php.ini.

Perhaps you are not targeting the correct php,ini (a very common mistake)?
To know the exact location of the php.ini being used by your server, please create a new .php file in your site root (say named test.php) and place the following in it -
Code: Select all
<?php
   phpinfo();
?>

Access the file in your browser and you'll see loads of info about your PHP configuration.
Find the info about php.ini in it and also the display settings for errors.
phpinfo-locate-php-ini.png
phpinfo-locate-php-ini.png (30.62 KiB) Viewed 3719 times

The listing will also show you the 'display_errors' setting we are targeting. Find what value it shows.
If it is on, make the changes to the indicated php.ini file and then run test.php again to make sure the changes get reflected in the error settings.

Make sure to delete the test.php file once you are done.

Hope this helps.

P.S. As an additional method, you may try placing the following at the very end of your couch/config.php -
Code: Select all
ini_set( "display_errors", "Off" );

Please check if this works.
You are my man!
Thanks very much for your help indeed.
7 posts Page 1 of 1
cron