Forum for discussing general topics related to Couch.
8 posts Page 1 of 1
Hi couch community,

I've done this in the past but I'm having a hard time finding the solution so I ended up here.
Question is: how can I create folders inside KCFinder? I want my client to be able to organise all his uploaded images in different folders.

Thanks in advance!

Right-clicking on the tree in the left sidebar of KCFinder will open a popup menu - it has the "create folder" item.

Hope this helps.
That's what I thought @KK, but that is simply not happening on my comp. I mean, it doesn't show any menu or options after a right click there.

I've rebooted everything multiple times and tried this on the latest chrome/safari versions on a new macbook pro M1 w/ macOS Monterey. KCFinder about mention a V2.51 and I'm running it on CouchCMS 2.3

Any other suggestions? Is there any update on the KCFinder I can try on couch?
Please check the devTools console to see if it reports any JS errors.
The error I get after opening KCFinder:

Deprecated Feature Used
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check .

Affected resources: 1 source: jquery.js:18
(which is located at couch/includes/kcfinder/js)

There is also another Issue:
Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform
But this one appears just by opening Couchcms. It doesn't seem related to the script
Thanks for the report but I don't think those issues are behind this problem.

I wonder (fear) if it is a generic issue with the latest versions of MacOS not playing fair with KCFinder?
I am not a MacOS user so would request our other users chancing upon this thread to please test this issue and report if they happen to be on a Mac.
Ohh sh** :( That's what I though because I ran everywhere online to understand what was happening. Let's wait to see if someone can give a little help around here...
Hi! Sorry to hear :(

I can say, I use a Mac and I have never run into this issue, using multiple browsers (Brave, Firefox, Safari, and etc). I’m using a MacBook Air 2020 M1, and I’ve used a MacBook Pro 2012 before — across all recent operating systems, High Sierra, Mojave, Catalina, Monterey.

I wonder if it might be a browser extension or some other third party app on your system getting in the way. You might try logging into a guest account and see if that works.

I’ll chime back in if I can think of anything else…
8 posts Page 1 of 1