Forum for discussing general topics related to Couch.
5 posts Page 1 of 1
Hello everybody! I've uploaded my website on the server and now am trying to load it, but it shows me error that its redirected. So when I type the name of the site http://www.something.eu ("something" is just for this topic) it loads like this http://www.something.euusers/login.php? ... Findex.php and it doesn't load the website. I can only understand that it redirects to users/login but I don't know why and how to fix it. Any ideas?
Hi,

It appears the URL is missing a slash (and is therefore malformed).
I presume you have explicitly added the site's URL to couch/config.php -
Code: Select all
// 1.
// If neccesary, define the full URL of your site including the subdomain, if any.
// V.IMP: Don't forget the trailing slash!
define( 'K_SITE_URL', 'http://www.test.com/subfolder1/subfolder2/mysite/' );

Please check the setting shown above and make sure it has a slash at the very end of it.

If, however, you have not added the URL to the config file then please use the setting above and do add the correct URL of your site there (not forgetting the slash).

Hope this helps.
Thank you for the reply, I've added the slash an now it shows the same error and the url looks like this:
"http://www.something.eu/users/login.php?redirect=%2Fusers%2Flogin.php%3Fredirect%3D%252Fusers%252Flogin.php%253Fredirect%253D%25252Fusers
%25252Flogin.php%25253Fredirect%25253D%2525252Fusers%2525252Flogin.php%2525253Fredirect%2525253D%
252525252Fusers%252525252Flogin.php%252525253Fredirect%252525253D%25252525252Fusers%25252525252F
login.php%25252525253Fredirect%25252525253D%2525252525252Fusers%2525252525252Flogin.php%2525252525253
Fredirect%2525252525253D%252525252525252Fusers%252525252525252Flogin.php%252525252525253Fredirect%25
2525252525253D%25252525252525252Fusers%25252525252525252Flogin.php%25252525252525253Fredirect%2525
2525252525253D%2525252525252525252Fusers%2525252525252525252Flogin.php%2525252525252525253Fredirect%
2525252525252525253D%252525252525252525252Fusers%2525252525..........................."and so on.

Just to add that with XAMPP everything was working fine.
If you are utilizing extended-users addon, I'd suggest you disable the login template of it (through config file within that addon's folder), See if the code login page of Couch works properly.
Thank you, I disabled the login and also from kfunctions disabled the extended users and after enabled them it somehow started working. Thank you for the help.
5 posts Page 1 of 1

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 5 guests