Forum for discussing general topics related to Couch.
2 posts Page 1 of 1
hello all, my webhost is going to start charging a premium for supporting out of date versions of PHP - so I need to upgrade ideally to PHP 7.2 (because they will also stop supporting PHP 7.1 towards the end of 2019). I guess I need to upgrade Couch from Version 1.4.5 before upgrading the PHP version - or there may be problems?

Shall I upgrade to Couch v.2.1? Will that be compatible with PHP7.2? Or even upgrade to Couch v.2.2 beta if that is compatible with PHP7.2?

Thanks for any advice ...
Hi,

Couch v2.2 is definitely compatible with PHP7.2. Can't comment on any of the older 1.x versions as I haven't tested them with PHP7.

Upgrading your sites from v1.4.5 to v2.2 shouldn't be too difficult, I think (of course, keep a backup of everything before undertaking that).
.
However, you may find it easier to first upgrade to v1.4.7.
It will require a mysqli patch (viewtopic.php?f=4&t=10165#p25183) and should work just the same as before.

I'd suggest you first do that. In case PHP7.2 throws tantrums with Couch v1.4.7, you may go ahead with upgrading to v2.2.

Hope this helps (do keep the 'backup' thing in mind).
2 posts Page 1 of 1

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest
(based on users active over the past 5 minutes)

Users browsing this forum: No registered users and 1 guest